Thursday, 30 April 2015

Happy Birthday to Me....Egnater Rebel30 mkII....

I have been looking for a new home use amp that would fit in with the Evil Robot....Something that would rock a bit like a Marshall....and as I have had an Egnater Rebel 30 before...."it died and was replaced with it's larger sibling the Renegade"....what could go wrong....


I was looking at a Fuchs Black Jack 21 mkII head from Thomann....dicked about for about a week looking at other amps and miss it....it was the last one they had....Guttered....Dr Z Remedy looked good but luckily no loop....I do need a loop....Then a Jackson Ampworks Briton 30 but this was getting expensive and the amp needs to be similar to the ER C30 and not a replacement....Whilst not as good as the Fuchs....the new and improved version of the Rebel 30 looked to be the best of a small list....but from it's first switch on it was clear that the  little Egnater had a problem....


At first I thought it might be just a bad tube....I could see by the glow coming from the EL84's the biasing was a little out....Egnater make it very easy with a multi meter to check the biasing and the EL84 side was way out running at 78mV instead of 40mV....Checked all the tubes....all came back as good....but even after a proper biasing the Rebel 30 seemed to be getting worse....Nothing I could do over the long Bank Holiday weekend apart from trying out different tubes and see if it would burn itself into a better sounding amp....lol....it didn't....


Got on the phone to Guitar Guitar on Tuesday to order up a replacement....only GG had other ideas....Bought on the 1st of April....Refunded on the 27th of April....not cool GG....Anywho....as for the fault....unfortunately GG never let me know what the problem was....if I had to guess it would be down to the WATTS circuit....this lets you dial the power from 30watts down to 1watt....this looks very similar to the output power scaling kits you can get from London Power....


It was clear the Watts circuit was not working properly....it was almost acting like a slow gate as you went from channel to channel....taking a few seconds to kick in and drop the output volume to where is was set....but the out of tune sound I was getting from the amp makes me think that the fault was the filter caps going bad....but to be honest....I don't have a clue what the problem was....It was so much hard work just playing it for the video that GG wanted of the fault before they would do anything....The thing was just plain nasty sounding and fought me all the time I was playing it....But would I get another one....

 
 If you cant see this video it's here....

Egnater's are well made...."love my Renegade"....yes built in China but it's an amp that no corners have been cut to save money....the Pre Amp is made up of 3 12AX7's....the FX Loop has it's own 12AX7 for the send and return....as does the Phase Inverter....If you were being picky....the only thing missing is a proper transformer choke....but some designs don't need them....Egnater's are built old school ish....no new mini surface mount crap....just plain old big components using thru hole mounting....it's a tube amp not a 9v pedal....when it goes wrong you're going to get it fixed yeah....trying fixing surface mount....


The output tubes were perfectly matched and the pre amp tubes all tested as being balanced....Egnater do seem to install better than average tubes in their amps....Love the red circuit board and it's red transformers....maybe a little too Mercury Red....but the little amp does never the less look cool....comes in it's own padded gig bag....big rubber feet....it's a lot of amp for the money....unless I find a Fuchs Black Jack 21 and if I can try one first and walk out with it under my arm I'll have another Rebel 30 without hesitation....


Just not from Guitar Guitar....Who are now on my list....lol....k.j.